Partycja systemowa ?

#1
Właśnie dokonałem dość sporej rekonfiguracji mojego zestawu mającej na celu wzrost wydajności i w niedalekiej przyszłości możliwość rozbudowy pamięci:
4x4TB - R5 z DS916+ trafiły do DX513 (zatoki 1-4)
2x2TB SHR z DX213 trafiły do DS916+ (zatoki 3-4)
W zatokach 1 i 2 DS916+ zagościły serverowe SSDki 240GB tworząc SHR 240GB na wolumen systemowy i VM
Zatokę 5 DX513 zaopatrzyłem w starego, ale sprawnego i trudnego do "zajechania" Cruciala M4 240GB jako cache odczytu dla wolumenu BTRFS na R5.
Po zainstalowaniu systemu na SSDkach, obsadzeniu wszystkich pozostałych dysków, DSM wystartował jak rakieta. Jeszcze przed inicjacją SSD Cache, wczytywanie czy odświeżanie miniatur zdjęć w folderach na R5 BTRFS (z poziomu windows) trwało bardzo krótko. W monitorze zasobów widać było jak bardzo pomaga przy tym SSD z wolumenem systemowy. Niestety, wyświetlana była informacja że dyski 3 i 4 mają niepoprawną partycję systemową lub są uszkodzone i system sugerował naprawę. No i coś mnie podkusiło żeby ją naprawić :/ Po tej naprawie dowiedziałem się że system buforuje wszystkie operacje zapisu nie na wolumenie na którym są instalowane wszystkie aplikacji, tylko właśnie na partycji systemowej. Czyli szybkość systemowego R1 z ultra-prędkości SSD spadła do poziomu HDD :evil:
Jest szybciej niż było jak system siedział na 4x4TB w R5 ale nie jest tak szybko jak może być. No i wpadło mi do głowy żeby z powrotem wykasować te partycje systemowe z 2x2TB hdd i pogodzić się z ostrzeżeniem.
Co o tym sądzicie (nadal system będize siedział na 2dyskach SSD więc raczej będzie poziom bezpieczeństwa jaki zapewniają NASy 2 dyskowe) ?
Pozdrawiam,
Paweł
DS1819+, 32GB ECC, 10GbE, DS916+ 8GB, DX513, DS710+, DX213, DS119j
RT2600ac

Re: Partycja systemowa ?

#3
No własnie zauważyłem. Ale tylko na dyskach w NASach, w DXach już nie.
Dlatego system po włożeniu do pracującego NASa 2 dysków z DX213, zgłosił że na 2 dyskach nie ma systemu albo są uszkodzone i chciał to naprawić. Była to tylko kwestia partycji systemowej, bo wolumeny które były na tych dyskach działały, wszystko z nimi było ok. Tylko ja w swojej niewiedzy, sadziłem że buforowanie zapisów będzie na volumenie stożonym na nowo swadzonych SSDkach a nie na partycji systemowej.
Dlatego teraz zastanawiam się nad powtórnym wywaleniem (po wyjęciu z NASa oczywiście) z tych 2 HDD partycji systemowej. chciałbym żeby system znów sygnalizował mi że je 2 z 4 dysków jej nie ma, ale nich zapindala nadal jak to na SSDkach (nie o start mi chodzi, ale o buforowanie operacji dyskowych). Nie wiem oczywiście które to partycję, ale mam nadzieję że podpowiecie ? ;)
Pozdrawiam,
Paweł
DS1819+, 32GB ECC, 10GbE, DS916+ 8GB, DX513, DS710+, DX213, DS119j
RT2600ac

Re: Partycja systemowa ?

#5
To mogłoby być dobre, ale ja chciałbym wywalić z nich partycję systemową bez ruszania pozostałych danych. Tak jak było na początku po migracji - kiedy system sugerował ku mojej zgubie żebym to naprawił (tzn nacisnął jeden przycisk który przywrócił "brakujące partycje systemowe na dyskach z DX213) - tzn. zrobił sobie źle ;)
Pozdrawiam,
Paweł
DS1819+, 32GB ECC, 10GbE, DS916+ 8GB, DX513, DS710+, DX213, DS119j
RT2600ac

Re: Partycja systemowa ?

#9
Niestety, wszystko wskazuje na to że nie da się w prosty sposób wywalić jednej z 2 małych partycji na początku dysku, żeby pozbyć się systemu, a zachować wolumeny.
Pozdrawiam,
Paweł
DS1819+, 32GB ECC, 10GbE, DS916+ 8GB, DX513, DS710+, DX213, DS119j
RT2600ac

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 0 gości