PHP 5.6 - wsparcie dla GD

#1
Witam,

Dziś zainstalowałem nową wersję DSM 6.1. Po instalacji pakietów brakuje mi wsparcia w PHP 5.6 dla biblioteki GD.
Po wpisaniu w linii komend "php -m" brakuje tego rozszerzenia. Poprzednio plik gd.so znajdował się w tej lokalizacji (/usr/lib/php/modules). Teraz go tam brakuje. Co ciekawe w konfiguracji WebStation w PHP settings jest wylistowany w rozszerzeniach (p.załącznik).
Ktoś wie jak przywrócić bibliotekę GD?

ps. korzystam z tej biblioteki w trybie CLI i wywołuję skrypt następująco:

Kod: Zaznacz cały

php -d extension=gd skrypt.php
błąd:

Kod: Zaznacz cały

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/gd.so' - /usr/lib/php/modules/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0

Kod: Zaznacz cały

$ php -m
[PHP Modules]
bcmath
bz2
Core
ctype
curl
date
dom
ereg
filter
hash
iconv
json
ldap
libxml
mbstring
mcrypt
openssl
pcntl
pcre
PDO
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
syno_compiler
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.
https://search.synopackage.com
https://www.facebook.com/synopackage/
Sprzęt:
DS718+ (apollolake): 2x2TB (WD RED) SHR ,2GB RAM
Poprzedni:
DS215j

Re: PHP 5.6 - wsparcie dla GD

#2
Chyba pospieszyłem się trochę z pytaniem, ale może się to komuś przyda, to odpowiadam :)

Przeszukałem wszystkie foldery i znalazłem plik gd.so w lokalizacji:

Kod: Zaznacz cały

/volume1/@appstore/PHP5.6/usr/local/lib/php56/modules
Wystarczy przegrać ją do /usr/lib/php/modules aby zadziałało jak należy.

Pozdrawiam,
xurc
https://search.synopackage.com
https://www.facebook.com/synopackage/
Sprzęt:
DS718+ (apollolake): 2x2TB (WD RED) SHR ,2GB RAM
Poprzedni:
DS215j

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości

cron