moments problem z logowaniem.

#1
Witam serdecznie. Proszę o pomoc. Posiadam ds 718+ i 10GB RAMu. Serwer podpięty jest pod stałe ip. Przekierowanie portów zrobione. Certyfikat zaimportowany. Logowanie się po zewnętrznym ip na komputerze działa. Uruchomienie moments na przeglądarce też działa bez zarzutu. Wszystko chodzi na https i certyfikacie. Problem zaczyna przy mobilnej aplikacji. Logowanie się po http czyli bez certyfikatu działa. Problem zaczyna się gdy próbuje w aplikacji uruchomić https.z certyfikatem. Aplikacja mieli mieli i wyrzuca żeby sprawdzić ip, quickonnect itp. Pytanie czy moments działa po https? Jeśli tak to co może być problemem ?


Z góry dziękuje za pomoc

Re: moments problem z logowaniem.

#4
Foxy pisze:
wt gru 11, 2018 12:32 pm
Pytanie czy moments działa po https? Jeśli tak to co może być problemem ?
Działa po HTTPS i po samym HTTP

Co masz ustawione w: Panel Sterowania > Portal aplikacji > Aplikacja

Może tam masz ustawiony inny port?
NAS:
[ main ] Synology DS1515+ | 6 GB RAM | DSM 6 | 5 x WD Red WD60EFRX ext4 RAID 5

Re: moments problem z logowaniem.

#5
po wejściu w aplikacje nie mam zaznaczone "włącz dostosowany port https i http". Gdy próbowałem zaznaczyć i wpisać numer portu taki sam jak loguję się do dsma to mi wyrzuciło komunikat, że ten port jest używany przez inną aplikację. Pozostawiłem odznaczone. Co ciekawe jeśli wchodzę do mobilnej aplikacji i podam port 5000 tj. http i nie zaznaczam suwakiem https to śmiga. Jak wpiszę przykład.com:5001 i zaznaczę https to nie chcę się zalogować.

Re: moments problem z logowaniem.

#8
Bez numeru portu zalogujesz się gdy port jest domyślny (5000 i 5001) lub gdy korzystasz z QuickConnect.

Przeczytałem cały wątek i jeszcze raz chcę doprecyzować.

Ustawiłeś przekierowanie dwóch portów na routerze np. (przykład dla portów domyślnych, bez zmiany w DSM)

http://mojadomena.pl:12345 > 192.168.1.100:5000
https://mojadomena.pl:12346 > 192.168.1.100:5001

Chodzi mi o to czy przekierowałeś oba porty czy tylko jeden? Pisałeś, że w przeglądarce działa tylko w telefonie nie chce. Upewniam się, bo jeśli te dwa przekierowania są zrobione dobrze i na komputerze działa, to na telefonie też musi.

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość

cron