Strona 1 z 1

Problem z odtwarzaniem filmów w przeglądarce

: wt mar 29, 2016 7:36 pm
autor: veg
Witam,

O moim problemie pisałem jeszcze na starym forum. Nie znalazłem rozwiązania, odpuściłem, zadowoliłem się odtwarzaniem filmów przez Kodi. Teraz wracam do tematu, bo nie daje mi on spokoju. Zwłaszcza po aktualizacji Video Station, które wygląda teraz tak ładnie, że aż chciałoby się móc z niego korzystać.

Czy komukolwiek udaje się bezproblemowo odtwarzać filmy za pomocą Video Station w przeglądarce? Mam na myśli taką sytuację, że w np. Firefoxie (może być też Chrome, czy nawet IE) wpisujemy ip serwera, logujemy się, odpalamy VS, klikamy na dowolny film po czym płynnie odtwarza się on w nowym oknie?

U mnie niestety to nie działa ;/ Próbowałem już chyba wszystkich przeglądarek i wszystkich możliwych wersji VLC. W zależności od konfiguracji efekty są różne. Film albo nie odtwarza się w ogóle (wyskakuje komunikat o nieznanym formacie), albo odtwarza się w jakości oryginalnej ale co jakiś czas obraz traci na płynności, albo odtwarza się w jakości wysokiej (oryginalna jest niedostępna, występuje to po całkowitym odinstalowaniu VLC) ale oznacza to transkodowanie materiału przez serwer (czego chciałbym uniknąć, chciałbym żeby obraz był przetwarzany przez komputer, na którym wyświetlamy film). Problemów nie mam tylko z formatem mp4, wszystkie inne niestety nie działają (i nie są to jakieś egzotyczne rozszerzenia).

Osoby, którym VS w przeglądarce działa chciałbym poprosić o informację jakiej przeglądarki i jakiej wersji VLC używają?

Pozdrawiam

Re: Problem z odtwarzaniem filmów w przeglądarce

: wt mar 29, 2016 9:31 pm
autor: psmanek
Wszystko działa, na każdej przeglądarce. Niestety system to OS X. Także nie da się tego porównać.

Re: Problem z odtwarzaniem filmów w przeglądarce

: pt kwie 01, 2016 10:03 pm
autor: jjLDN
Temat rzeka i wałkowany od chyba "wieków".
Nie ma jednoznaczej odpowiedzi.
Generalne uwagi to:
1. upewnij się, że łączysz się po http, gdyż po https są problemy ze streamingiem video.
2. w DSM w Control Panel w Application Portal ustawione powinny być porty dla VS http=9007 i https=9008. Kliknij na 9007 i spróbuj uruchomić video.
Osobiście używam Plex servera ostatnio, gdyż powoduje najmniej problemów. Aplikacje klienckie mam na andoridach, iOSach i tv, no i w przeglądarce można wejść na webgui serwera i tam dla webowego playera w przeglądarce można ustawić czy ma być Direct Play, Direct Stream czy też transkodowanie.

Re: Problem z odtwarzaniem filmów w przeglądarce

: pn kwie 04, 2016 4:45 pm
autor: veg
Dzięki za odpowiedź...

To raczej kwestia konfiguracji przeglądarki/pluginu, a nie portów.
Po odinstalowaniu wszystkiego poza Firefoxem filmy mp4 odtwarzają się bezproblemowo (bez transkodowania). Problemy pojawiają się z innymi formatami, których przeglądarka sama w sobie nie obsługuje. Stąd samo Synology sugeruje konieczność wspomagania się dodatkowym, zewnętrznym programem VLC (i pluginem), który jednak w moim przypadku nie bardzo chce współpracować ;/
Dlatego zapytałem jakich wersji przeglądarek i odtwarzaczy używają Ci, którym odtwarzanie wszystkich formatów przez WWW działa dobrze.

Plex pewnie byłby jakimś rozwiązaniem, ale wolałbym zostać przy Video Station, które działa na wszystkich moich pozostałych urządzeniach (WD TV Live, smortfon, tablet).

Re: Problem z odtwarzaniem filmów w przeglądarce

: śr kwie 06, 2016 10:39 pm
autor: jjLDN
Porty podałem tylko po to, żebyś miał pewność, że nie przenosi Cię automatycznie z http na https. Zwłaszcza jeśli tak masz ustawione w Control Panelu DSM. Po portach łatwo poznać.
Przecież nikt nie broni Ci udostępniania tych samych filmów na obu przez oba servery - DS Video i Plex.
Osobiście też używałem swego czasu do wszystkiego DS Video, bo mam chyba praktycznie wszystkie systemy operacyjne (poza Windows Phone) i DS Video jest ciekawą opcją.
W Samsung TV niestety DS Video działa koszmarnie i faktycznie Plex radzi sobie lepiej. Używam Plex serwera tylko ze wględu na tv.

Re: Problem z odtwarzaniem filmów w przeglądarce

: wt kwie 12, 2016 10:18 pm
autor: Slartibartfast
A jak "sięgasz" do DS? Przez QuickConnect/zewnętrzne IP czy wewnętrzne IP?
Nie korzystam z VS zdalnie, tylko w domu więc łączę się po wewnętrznym - jest najszybciej. Z reguły oglądam przez DLNA/Chromecast na TV, ale parę razy odpalałem na kompie i nie widziałem zacięć. Korzystam z IE oraz Edge, nie mam VLC.

Re: Problem z odtwarzaniem filmów w przeglądarce

: ndz kwie 30, 2017 9:30 am
autor: thorgal
Miałem problem jak w pierwszym poście - Sony Bravia EX650 smart ale bez szału - plex odpada bo przy próbie odpalenia na TV wyskakuje komunikat że mało pamięci ma TV. Po ostatniej aktualizacji DS Video odtwarza mi więcej formatów (mkv, mp4, nie wszystkie avi-kwestia kodeka xvid nie wszystkie wersje odtwarza ) w przeglądarce przez chromecast na TV. DS potrzebny jest mi głównie do wrzucania video na TV np w smartphonie włączam film na TV dla dziecka, serwer multimediów też kuleje bo nawet nie widzi telewizor .m2ts a to format który po usb śmiga na tv, tylko mp4 z poziomu serwera widać na TV - na wersji DSM 5 widział wszystkie pliki.